Вы здесь

Настройка CUCME с нуля: основные настройки (Часть 1)

Какие настройки необходимо сделать на маршрутизаторе, чтобы у вас зазвонил первый IP телефон? Данная статья приводит краткую теорию, и приводит практические шаги, необходимые для построения телефонной сети на основе Cisco Call Manager Express.
В первой части мы рассматриваем самые основные настройки CUCME.
Рассматриваются шаги загрузки телефона и методы диагностики проблем в среде CUCME.

Шаги загрузки IP Phone

Очевидно, как минимум, мы должны дать возможность телефону нормально загрузиться, поэтому рассмотрим шаги его загрузки.
(1). Cisco IP Phone подключается к порту коммутатора. Если телефон и коммутатор поддерживают стандарт PoE, IP телефон получает питание от кабеля Ethernet. Если нет, то телефон нужно запитать от розетки.
(2). При включении коммутатор Cisco по CDP отдает телефону информацию о voice VLAN.
(3). Телефон шлет DHCP-запрос на его voice VLAN. Сервер DHCP отдает информацию адресации, включая IP address, subnet mask, default gateway, DNS server и т.д. Тут следует отметить что телефон также получает от DHCP так называемую option 150. Это особая опция, которая включает в себя адреса TFTP серверов.
(4). После того как телефон получил информацию о сервере TFTP, он к нему подключается и загружает конфигурационный файл. Конфигурационный файл в себя включает список серверов Call Processing Agents или попросту CUCME, которых может быть несколько.
(5). IP телефон подключается к Call Processing Server или к CUCME.

Рассмотрим практический пример со схемой представленной ниже:

CUCME_Phone_connection1_0.jpg
В данном примере мы настроим маршрутизатор c2951 и коммутатор c2950 так, чтобы у нас зазвонили IP телефоны.

(1) Настройка Voice VLAN

В нашей сети имеются как компьютеры, так и телефоны.
Мы создадим два VLAN-a:
VLAN 10 для компьюетров
VLAN 20 для телефонов
Собственно VLAN 20 и будет называться как Voice VLAN.

Т.к. у коммутатора кофигурация отсутствовала, минимальные настройки:
hostname c2950
vtp mode transparent

Создадим VLAN-ы
vlan10
name comp

vlan 20
name voip

Настроим порты коммутатора для телефонов:
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast

По сути при такой настройке между портом и телефоном поднимается транк, т.е. через одно соединение идет трафик обоих VLAN-ов.
CUCME_Phone_connection1.jpg
На рисунке видно, что трафик компьтера, т.е. VLAN 10 никак не тагируется и передается компьютеру, при этом телефон работает как обычный коммутатор.
Трафик VLAN 20 же тагируется. Это позволяет в одном линке пересылать фреймы обих VLAN-ов.

Маршрутизатор в данной схеме является шлюзом по умолчанию для обоих подсетей. Поэтому соединение маршрутизатора и коммутатора будет транковым

Настройки коммутатора:
interface FastEthernet0/24
switchport mode trunk

Настройки порта маршрутизатора:
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description Comp
encapsulation dot1Q 10
ip address 10.0.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
description voip
encapsulation dot1Q 20
ip address 10.0.20.1 255.255.255.0

Прочие настройки: настроим на коммутаторе IP адрес и доступ
interface Vlan10
ip address 10.0.10.5 255.255.255.0

aaa new-model

username admin privilege 15 password 0 adm

line vty 0 4
privilege level 15

enable secret 0 adm

service password-encryption

Аналогичные настройки дадим на c2951
aaa new-model

username admin privilege 15 password 0 adm

ip http secure-server
ip http authentication local

line vty 0 4
privilege level 15

enable secret 0 adm

service password-encryption

Таким образом, на данном этапе маршрутизатор уже должен успешно пинговать адрес коммутатора:
ping_test1.jpg
Если подключить телефон, то он конечно включится, но будет отображать "Phone not Registered".
У него еще нет IP настроек, которые он должен получить от сервера DHCP.
phone_not_registered_0.jpg

Мы в этом кстати можем убедиться, заглянув в сам телефон и выбрав Phone Information - там поле IP адреса будет пустым.
Также можно на коммутаторе дать команды:
show cdp neighbors
show cdp entry
show_cdp_no_ip.jpg

(2) Настройка DHCP сервиса

В качестве DHCP сервера сделаем маршрутизатор.
Мы создадим два пула на маршрутизаторе.

ip dhcp excluded-address 10.0.10.1 10.0.10.10
ip dhcp excluded-address 10.0.20.1 10.0.20.10
!
ip dhcp pool VOIP_SCOPE
network 10.0.20.0 255.255.255.0
default-router 10.0.20.1
option 150 ip 10.0.20.1
dns-server 10.0.10.1
!
ip dhcp pool COMP_SCOPE
network 10.0.10.0 255.255.255.0
default-router 10.0.10.1
dns-server 10.0.10.1

Отметим здесь наличие опции 150 в настройках VOIP_SCOPE. Эта опция указывает телефону на TFTP сервер, откуда будет подгружаться конфигурация телефона.
Также в обоих скопах мы исключили адреса 1 - 10, зарезервировав их для тех нужд (сервера, коммутаторы и т.д.)

На этом этапе уже можно включить телефон. Он загрузится, но будет отображать Phone not Registered, т.к. мы еще не настроили ни TFTP сервер, ни CUCME.
phone_not_registered.jpg
Тем не менее телефон и компьютер уже получат свои IP адреса.
На телефоне это можно посмотреть нажав:
* -> Phone Information -> Ip Address
phone_information_ip_address.jpg

На коммутаторе телефон будет виден по CDP:
show_cdp_ip.jpg

Указанный ip адрес телефона должен пинговаться и также мы можем зайти на http-страницу телефона:
Выберем там network setup
ip_phone_http.jpg
ip_phone_http2.jpg

Тут следует выделить поля Unified CM 1 и 2 это собственно есть список Call Processing Agents, который телефон должен подгрузить из сервера TFTP. Сервер TFTP-то у нас получен (через опцию 150), но сам сервер еще не настроен.

Настройка DNS server

DNS сервер необходим телефону для разрешения имени CUCME в IP адрес. Вообще с именами лучше не связываться и везде прописывать именно IP адрес, но DNS сервис нужно все же настроить в любом случае. Им могут пользоваться не только телефоны но и компьютеры.
Настроим маршрутизатор в качестве кеширующего DNS сервера:
ip domain lookup
ip domain timeout 2
ip domain name office.local
ip host c2951 10.0.20.1
ip host c2951.office.local 10.0.20.1
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip dns server

ip domain lookup - включает трансляцию имён в ip адреса основанную на dns. Этот параметр включен по умолчанию. Часто его выключают чтобы маршрутизатор не "зависал" при вводе ошибочной команды, но для нашей цели его необходимо включить.
ip name-server - этот параметр задаёт адрес одного или нескольких серверов имён (dns). Приоритет определяется сверху вниз.
Автор тут включил общедоступные сервера (8.8.8.8 и 8.8.4.4), вы же можете сюда добавить сервера предоставляемые местным провайдером.
ip domain name - задаёт имя домена по умолчанию для пользователей Cisco IOS software для разрешения "неопознаных" доменных имён (имена без суффикса.
ip dns server - включаем собственно кеширующий DNS сервер на циске
Конструкция ip host c2951 10.0.20.1 работает подобно файлу hosts в windows.
Мы прописали имена c2951 и c2951.office.local как раз на случай если кто-то полезет на это имя. Такое бывает иногда с MGCP или в настройках CUCM.
Настройка DNS server подразумевает подключение маршрутизатора к интернет тем или иным способом, что выходит за рамки данной статьи.

Настройка NTP

Настройка точного времени необходима в работе множества сетевых сервисов.
К примеру точные значения времени играют важную роль в различных сервисах безопасности, в отображении логов.
При использовании CUCME время отображается на телефонах, во временных метках голосовой почты или записях CDR.
В большой сети и при большом количестве устройств имеет смысл синхронизировать одно или два "главных" устройства с источниками извне, а все остальные в свою очередь синхронизировать с мастерами.

На маршрутизаторе вводим команды и сделаем его "главным":
service timestamps log datetime
clock timezone MSK 4
ntp master 2
ntp update-calendar
ntp server 64.90.182.55
ntp server 62.117.76.138
ntp server 81.2.117.228
ntp server 88.147.254.228

Настройка NTP подразумевает подключение маршрутизатора к интернет тем или иным способом, что выходит за рамки данной статьи.

Настройка сервера TFTP

Во время загрузки IP телефону необходимо связаться с сервером TFTP.

В общем случае TFTP сервер не обязательно совпадает с CUCME, т.к. маршрутизатор не спроектирован на обслуживание большого количества телефонов, да и объем Flash не бесконечен. Но в нашем случае мы запустим TFTP на все том же маршрутизаторе.

По сути, сервер TFTP играет роль файлового сервера в сети телефонии. Телефоны загружают с него файлы конфигурации, а также файлы прошивок.

Файлы конфигурации включают в себя такую информацию как IP адреса и порты серверов CUCME, а также имена файлов прошивки, которые должен загрузить телефон.
Файлы конфигурации индивидуальны для каждого телефона, но при первом подключении таковой отсутствует. В этом случае телефон загружает файл по умолчанию: XMLDefault.cnf.xml. Затем в процессе регистрации CUCME создает уже индивидуальный файл, которым телефон уже будет пользоваться в штатном режиме.

Файлы прошивки необходимо загрузить с сайта Cisco.
Например для телефона 6961 файлы будут:
SCCP69xx.9-0-3-b.loads
BOOT69xx.0-0-0-14.zz.sgn
DSP69xx.0-0-0-3.zz.sgn
SCCP69xx.9-0-3-0-b.zz.sgn

Их необходимо скопировать на Flash
затем дать команды на маршрутизаторе :
tftp-server flash:SCCP69xx.9-0-3-b.loads
tftp-server flash:BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash:DSP69xx.0-0-0-3.zz.sgn
tftp-server flash:SCCP69xx.9-0-3-0-b.zz.sgn

Активируем сервис CUCME, поочередно даём следующие команды:
telephony-service
max-ephones 24
max-dn 48
ip source-address 10.0.20.1 port 2000
cnf-file location flash:
load 6921 SCCP69xx.9-0-3-b.loads
load 6941 SCCP69xx.9-0-3-b.loads
load 6961 SCCP69xx.9-0-3-b.loads
create cnf-files

Поочерёдно потому, что некоторые команды будут требовать подтверждения лицензионного соглашения.
Отметим смысл некоторых команд:
max-ephones 24 - максимальное количество телефонов которое маршрутизатор будет поддерживать.
max-dn 48 - максимальное количество номеров.
max-ephones и max-dn влияют на количество выделяемой памяти; также параметр не должен быть больше количества приобретенных feature licenses.
ip source-address - определяет на каком адресе маршрутизатор будет ожидать регистраций.
cnf-file location flash: - определяет местоположение конфигурационных файлов

create cnf-files - после этой команды будут созданы конфигурационные файлы
load - команда определяет какая модель телефона будет использовать какую прошивку. Без этой команды телефон будет использовать имеющуюся прошивку и не будет пытаться обновиться.

После выполнения данных команд телефон может начать загрузку прошивки (если его локальная не совпадает с той что на CUCME), после этого телефон должен зарегистрироваться на CUCME.
На консоли мы увидим следующие сообщения
register_phone.jpg

На самом телефоне мы увидим:
register_phone_screen.jpg
Телефон зарегистрировался, но мы еще не настроили номер, поэтому на экране он не отображается, а только дата и время. Если поднять трубку - она не загудит.

Проверить состояние зарегистрированных телефонов мы можем командой:
show ephone summary
show_ephone_summary.jpg

Настройка Ephone и Ephone-DN

В среде CUCME есть понятия Ephone и Ephone-DN.
Ephone - это объект в системе CUCME имеющий отношение к физическому телефону. Система различает Ephone друг от друга их MAC адресами.
Ephone-DN - представляет номер линии, или Directory Number. Физический телефон в общем случае может иметь несколько линий, т.е. до него можно дозвониться по нескольким номерам.

Настроим ephone-dn для нашего телефона:
ephone-dn 1 dual-line
number 101
description Natalia Askarova
name Natalia Askarova

Настроим ephone для нашего телефона:
ephone 1
mac-address C84C.759C.B7A7
type 6961
button 1:1

Здесь мы привязали физический телефон к объекту ephone 1 через его MAC адрес.
MAC адрес можно посмотреть в меню телефона Settings.
button
:
- данная команда привязывает номер ephone-dn к физической кнопке телефона. Т.е. при входящем звонке эта кнопка будет мигать. В нашем случае команда button 1:1 привязывает к первой кнопке ephone-dn 1.

После подобных изменений телефон необходимо перезагрузить, это можно сделать двумя способами:
- Телефон по питанию
- Зайти conf t > ephone 1 > restart

После перезагрузки телефон уже будет отображать свой номер.

Теперь мы можем проверить настройку нашего телефона:
show ephone
show_ephone.jpg

Аналогично мы можем настроить второй телефон. И теперь телефоны смогут осуществлять звонки друг другу.

Настройка телефона с помощью CCP

Cisco Configuration Professional (CCP) - это графическая оснастка, позволяющая конфигурировать маршрутизатор вне командной строки.

Для доступа к глобальным установкам CUCME идем по пути:
Configure - Unified Comunications - Telephony settings

Для настройки номера телефона идем:
Configure - Unified Comunications - Users, Phones and Extensions > Extension > Create
CCP_extension.jpg

После этого настраиваем физический телефон:
Configure - Unified Comunications - Users, Phones and Extensions > Phones and Users
CCP_Phone.jpg

Комментарии

Почему бы вам не развить данную тему и не написать продолжение? Очень поучительно и весьма занимательно получается у вас. Жду с нетерпением продолжения этой темы.

Очень толковый мануал для новичка. Респект и уважуха, а главное желание продолжать...

Спасибо большое! Очень грамотно написанная статья!

Спасибо за статью. Для полноты статьи не хватает только настроек для стыка с оператором связи через E1 или FXO интерфейс.

А как изменятся команды, если TFTP-сервер не маршрутизатор, а отдельный компьютер ? Спасибо.

Аватар пользователя Kelkh

Добрый день!
Интересует система записи разговоров под cisco CME. Какие есь варианты решений?

Oreca
sip-trunk+aster.
UCCX(raw2wav)

TOP

Спасибо, очень грамотно.

Добрый вечер.
Скажу так: на базе данной статьи и немного мозгов - сел за 2901 с voice bundle и настроил : через 40 минут у меня уже все звонили через sip.
Автору большое спасибо.

Никогда не писал коменты, но тут пришлось, реально помогло - Да хранит вас ASA. спасибо за статью

Добрый день! Очень понравилась первая часть. А как получить доступ ко второй части? При переходе пишет "У вас нет доступа к этой странице." :(

Отличная статья, расстривает лишь отсутствие доступа ко второй части по ссылке http://ciscomaster.ru/node/94 исправте плжст!

Для записи у cisco появился продукт cisco mediasense. Если есть серверные мощности то платить не придётся

Добрый день, а можно получить доступ ко 2 части?

Здравствуйте.Спасибо за проект.
я хочу подсоединить к CUCME "device analog phone" через VG224.
Вопрос как происходит регистрация портов , таким же образом как и ephone по mac-address:ANXXXXXXXXXXXXXX.
Заранее спасибо.

Здравствуйте, А как можно получить доступ к циклу статей Настройка Call Manager CUCM с нуля?

Добавить комментарий

Filtered HTML

  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Допустимые HTML-теги: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и абзацы переносятся автоматически.

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и абзацы переносятся автоматически.
CAPTCHA
Этот вопрос задается для того, чтобы выяснить, являетесь ли Вы человеком или представляете из себя автоматическую спам-рассылку.
Target Image